Как да интегрираме актуализации, драйвери и езикови пакети в инсталационния диск на Windows 7

65 мнения в тази тема

Отговорено

Благодаря!

Пробвах точно по този начин, но при 2.в ми даде грешка и реших че трябват някакви допълнителни команди.Но явно при мене е грешката.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Насе,дай едно рамо колега!!!Имам си свой(направен)Windows 7,всички верии на бг с всички обновления.Искаме ми се обаче да му лепна и Net 4,но да е изцяло "silent" инсталацията,демек да се инсталира при самото инсталиране на операционната система.Ако не се лъжа трябва да изглежда нещо такова :

Quote

Setup=dotNetFx35Setup.exe /qb /norestart /lang:yourlanguagecode

Silent=1

Overwrite=2

Update=U

Title=.NET Framework 4.0 SP1

Но qb трябва да е само q или аз оплескавам нещо,също така ще те помоля и за команда за интегриране ако не те затруднява.Разбира се ако греша,ще се радвам да ме поправиш и светнеш!!!!!

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Малко ще ти е трудно да го интегрираш, по вероятно е да се инсталира след инсталацията, виж намери готов ad-don и пробвай да го интегрираш с командата за пакети.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Не става Насе,мъчих,струвах скрипта си е ок,но не намира пътя лъм файла ..........ще се търси начин,ще се модифицира явно самия достъп до директорията

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Здравейте, току що си интегрирах бг език на x86 версия безпроблемно. Сега пробвам и със x64 и ми дава грешка:



Error: 1784 The supplied user buffer is not valid for the requested operation. The DISM log file can be found at C:WindowsLogsDISMdism.log

И това след като моунтна install.wim с командата :


dism /Mount-Wim /WimFile:C:7WorkDVDsourcesinstall.wim /index:4 /MountDir:C:7WorkWIM

за x64 Ultimate.

Някакви идеи?

Оправено!

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Искам да направя инсталационен диск с активирано копие на windows 8,но файловете за активацията не са в папката C:WindowsServiceProfilesNetworkServiceAppDataRoamingMicrosoft.Къде се намират?

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Насе...някакъв шанс да подпукаш темата и за Windows 8 има ли???? :poklon: :poklon: :poklon:

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

За сега НЕ.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Командите за Win 7 безпроблемно работят ако искате да интегрирате и в Windows 8.Тествано...баца! :cheers:

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Здравейте,

индекса за Win 8.1 какъв е ?

Pro – 1 Enterprise – 1 Core – 2 , това ли са правилните индекси ?

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Това е само за windows 7, за 8 се ползват други команди и друг инструментариум !!!

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Кодовете работят и с Windows 8.1 .iso образи, успешно интегрирах езиков пакет с избор на език по време на инсталацията!

Тествани на Windows 8.1 Pro VL x64 BG (единствено промених dism /Mount-Wim /WimFile:C:7WorkDVDsourcesinstall.wim /index:4 /MountDir:C:7WorkWIM index 4 с 1).

Официален туториал от Микрософт за интеграция на езиков пакет http://technet.microsoft.com/en-us/library/hh824900.aspx

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Само че не се ползва WAIK , а Windows Preinstallation Environment

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Инсталирам “Windows Assessment and Deployment Kit (ADK) for Windows® 8“, конзолата за работа е “Deployment and Imaging Tools Environment“.

С този код единствено не пасват нещата xcopy C:7WorkLPsourceslicense* C:7WorkDVDsourceslicense /cherkyi но в крайна сметка пакета е интегриран.

Да попитам в сайта на Микрософт който съм посочил по-горе този код какво ще рече xcopy D: C:my_distribution , имам предвит какво трябва да има в посочената директория, “Windows product media“ не трябва ли да се намира разархивирания iso образ в C:my_distribution ?

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Малко off topic,моля админа да ме извини!Някой има ли идея как се интегрират update-тите на office 2013.Начина ,който бачкаше за 2010(копване в папката Updates),за съжаление не работи при Office 2013.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Здравейте.

Извинявам се много за това че повдигам стара тема но до сега не съм интегрирал предварително драйвери в образ на Windows.

Кои файлове по-точно от този драйвер "VIA_V-RAID_SoftwarePackage_V5" трябва да се копират в C:\7Work\DRIVERS?

Това е драйвера

http://i.imgur.com/0thkDpw.jpg http://i.imgur.com/W5qsxyH.png

Благодаря ВИ много!!!

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Най вероятно се намират в папкта VRAIDDrv

1

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Ей, вчера ми светна крушката покрай тази тема. Насе, форумната дистрибуция има ли набити някакви допълнителни драйвери в самата инсталация (не във вече инсталираната система) или boot.wim не си го пипал?

1

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Няма слагани каквито и да е допълнителни драйвери.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Днес направих един експеримент, но се оказа неуспешен. Поради зачестилите случаи на пуснати в продажба чупентии за по 450-500 лева (нетбуци с лепени цицерони, Win 8 и никакви USB 2.0 портове), реших да интегрирам в boot.wim всички USB 3.0 драйвери за всички контролери. За целта намерих наготово в насипно състояние всички тях на driverpacks.net (пакета Chipset). Интегрирах ги и след това направих флашка, като след това замених стоковия boot.wim с този който направих. Резултатите бяха от трагични по-трагични: на служебната настолна машина (дъно AsRock с Intel USB 3.0 контролер) инсталацията запали, но всички USB портове (USB 2.0 и USB 3.0) угаснаха. На лаптопа ми инсталацията запали и с нея и USB 2.0 порта, но трите останали порта (USB 3.0) умряха.

Явно някой от тия драйвери не трябва да е там, защото бърка всичко (предполагам някой от интелските).

1

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Не Филипе, проблема е друг, драйверите трябва да са в Install.wim затова като запали не ги намира там където трябва.

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Там пък за какво? Мен ми трябват само по време на инсталацията, колкото да познае контролера и да намери флашката с инсталационните файлове, закачена на USB 3.0 порт. За тази цел тези драйвери трябва да се интегрират само в boot.wim (Windows PE сесията). Ако бъдат интегрирани в Install.wim, те ще бъдат качени и на вече новоинсталираната система, което не ми е цел, също така този файл не се чете за драйвери по време на старта на инсталацията, ползват се само интегрираните в boot.wim. Нали се сещаш, че като не може да ти вдигне USB 3.0 контролера и да прочете флашката, Windows PE сесията няма как да открие Install.wim, от който да извърши инсталацията.

Edit: имам известен напредък. Проблема на настолната машина се оказа чисто заради липса на драйвер. Служебната машина е Haswell архитектура, а Intel имат два USB 3.0 драйвера за Windows 7: за седма серия чипсети (Ivy) и за осма/девета серия чипсети (Haswell/Broadwell). В случая втория липсваше и след като го добавих, инсталацията си тръгна както трябва.

Лаптопа ми обаче е друг случай. Всичките ми опити да подкарам контролера се оказаха неуспешни. Правилния драйвер вече е в boot.wim, но USB 3.0 контролера (Intel, седма серия) не пали. По-интересното е, че без него пали, вярно, в USB 2.0 режим, но работи и това е напълно достатъчно за да си направи човек инсталацията. На настолната машина без нейния драйвер работи по абсолютно същия начин, тръгва в USB 2.0 режим и работи. Доколкото съм чувал, интелските контролери, за разлика от останалите, могат да работят в USB 2.0 режим без специален драйвер за това, което ме навежда на мисълта, че в тия евтини нетбуци контролерите са други, защото подобен проблем имаше на USB 3.0 портовете на предния ми лаптоп ProBook 4330s, който беше с контролер NEC/Renesas.

Не знам какво точно се случва със стандартните драйвери (тези, които вече са там), след като интегрирам тези, изглежда се получава нещо като вземане на приоритет пред тези на Microsoft и това би обяснило ситуацията.

2

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Възможно е и това да се случва с приоритета, но съм забелязал че след зареждане на инсталатора почва да зарежда драйвери от Install.wim тоест търси там, това при инсталиране от флашка, незнам защо не запазва вече заредените от инсталатора :bn:

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Преди малко пробвах да интегрирам драйверите за USB 3.0 в Install.wim и резултата потвърди теорията ми: драйвери, които трябват за ползване само по време на инсталацията, се интегрират само в boot.wim. Install.wim съдържа единствено образа на вече инсталираната система, разделен на няколко издания, както и инструментите за слединсталационна манипулация на този образ (postinstall setup) и това е всичко, нищо повече, нищо по-малко. Все пак, както отбелязах по-горе, няма как да стигнеш до зареждане на данните от Install.wim, ако преди това първата фаза на инсталацията (boot.wim) не ти е вдигнала USB 3.0 контролерите. Наличието на тези драйвери в Install.wim единствено определя тяхното наличие при първия старт на система, а това в случая мен не ме интересува.

Накратко, с интегрирането на драйверите в Install.wim нищо не се промени, USB 3.0 контролера на лаптопа ми пак не запали, точно както преди. Явно нещо USB 3.0 драйвера за Intel Series 7 не се погажда особено с първата фаза на инсталацията, за разлика от драйвера за Intel Series 8/9, който работи както трябва (тествано на Haswell дъно с Intel контролер). Снощи дори пратих модифицирания boot.wim на Йоан, който каза, че с него въобще не е стигнал до инсталацията на лаптопа му (Ivy платформа).

2

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Отговорено

Искам да си интегрирам всички драйвери за лаптопа, когато ги разархивирам от .rar се образува папка в която има файлове и .exe файла от който се инсталира драйвера.Като не трябва драйвера да е в .exe, или .rar, в какъв вид трябва да са драйверите които се интегрират в install.wim?

0

Сподели публикацията


Адрес на коментара
Сподели в други сайтове

Създайте нов акаунт или се впишете, за да коментирате

За да коментирате, трябва да имате регистрация

Създайте акаунт

Присъединете се към нашата общност. Регистрацията става бързо!


Регистрация на нов акаунт

Вход

Имате акаунт? Впишете се оттук.


Вписване